Can't run the .rhi installer for Rhino 6

I can’t install Fologram for Rhino 6. I’ve looked at a ton of these support threads and nothing is working. When I try to run/open the .rhi file it just opens up a bunch of new blank rhino files continuously, and I don’t even see the prompt where it asks to install “just for me.” I tried going to the McNeel website for support and it says to download and run some fix, but I cannot download it. I am at a loss here. Any help would be appreciated, thanks!

Hi @jaljacob
Thanks for getting in touch. To confirm, have you tried running rhifix.exe from here? Troubleshooting RHI Installers [McNeel Wiki]

Cheers

Hi, yes I’ve gone to that website to try and download that fix, but when I click on it nothing happens so I can’t download it and therefore cannot run it.

Hi @jaljacob
It seems like the issue is that the .rhi file association isn’t correct, and that the rhifix isn’t working for you. We should be able to work around this; could you please try the following:

  1. Download Fologram
  2. Right click on the .rhi installer and select Open With
  3. Choose Look for another app on this PC or similar
  4. Locate C:\Program Files\McNeel\Rhino Installer Engine\x64\rhiexec.exe

This should force the installer to load correctly.

Please let me know how you go.

Cheers

Hi, just an update - I was able to download the rhifix and ran it, but it failed. I contacted Mcneel support and they referred me back to you guys.

As for the steps above, I don’t have a McNeel folder in Program Files, it only contains a folder named Rhino 6, and there is no rhiexec.exe anywhere in it.

What should I try next?

EDIT—

I repaired my Rhino install, after which the mcneel folder showed up. I tried the above steps and it worked. Thank you for your help!!

Glad that worked for you! And thanks for posting the solution for others that may come across this issue.

Cheers