Device Connection Failing

Hello, Part of an incoming graduate class from Georgia Tech. Excited to be here but having trouble getting started. Error connecting to my device. I am getting an error message that says it failed to start the http server. Research is showing it may be a firewall or .NET issue. Working with my IT we confirmed no security flags and updated framework.

I should note that this is a work computer and we log into a VPN connection to establish the Rhino license. Once connected I am able to disconnect from the VPN but problem persists. Company uses Sentinel security.

Any issues popping up with these characteristics before? Possible fixes? Any information that I can provide to help the cause?

Hi @kmill
Thanks for getting in touch. A diagnostic log from Rhino might help us out here. Could you try:

  1. Open the Fologram for Rhino panel
  2. Double click the status bar (which says “Ready” by default)
    image
  3. Open the “Log” tab which has appeared
    image
  4. Change the dropdown menu to “Trace”
  5. Click the “Play” button on the status bar
  6. Click “Open Log File”
    image
  7. Save a copy of that file and attach here or email it to support@fologram.com

Hopefully this will reveal some additional info!

Cheers
Cam

20:08:15.027 | DEBUG | ______________Fologram.IO.Rhino3d.UI.MainViewModel | Logging to C:\Users\kmiller\AppData\Roaming\Fologram\logs
20:08:15.612 | _INFO | _________________________Fologram.IO.NetworkStatus | Network up.
20:08:15.612 | _INFO | _________________________Fologram.IO.NetworkStatus | Network is connected.
20:08:16.299 | DEBUG | ___________Fologram.IO.Rhino3d.UI.NetworkViewModel | Setting selected network to NetworkProperties Adapter=Qualcomm QCA61x4A 802.11ac Wireless Adapter Status=Up Type=Wireless80211 Address=[10.0.0.165] HostName=slamat14073n SubnetMask=255.255.255.0
20:08:16.299 | DEBUG | ___________Fologram.IO.Rhino3d.UI.NetworkViewModel | Setting selected network to NetworkProperties Adapter=Qualcomm QCA61x4A 802.11ac Wireless Adapter Status=Up Type=Wireless80211 Address=[10.0.0.165] HostName=slamat14073n SubnetMask=255.255.255.0
20:08:25.214 | _INFO | ________________________________Fologram.IO.Logger | Setting log verbosity to Trace for “console”
20:08:52.189 | DEBUG | ___________________________Fologram.Network.Server | State changed from Closed to Opening
20:08:52.189 | DEBUG | ___________________________Fologram.Network.Server | Created http server on 0.0.0.0:9090
20:08:52.211 | ERROR | ___________________________Fologram.Network.Server | WS: The current output action has been changed.
20:08:52.211 | DEBUG | ___________________________Fologram.Network.Server | Adding websocket service 0.0.0.0:9090/io
20:08:52.228 | ERROR | ___________________________Fologram.Network.Server | Exception when starting http server on 0.0.0.0:9090 (The underlying listener has failed to start.)
The underlying listener has failed to start.
Task.Execute => Task1.InnerInvoke => Server.<Open>b__59_2 20:08:52.235 | _INFO | ___________________________Fologram.Network.Server | WS: The server is not started. 20:08:52.235 | DEBUG | ___________________________Fologram.Network.Server | State changed from Opening to Closed indent preformatted text by 4 spaces`

Thanks for the quick response Cam, log pasted above. Further exploration with my IT team today revealed that it must be computer specific. They were able to perform the connection successfully on other machines in the office as well as remote. We tried creating a new profile and fresh install on my computer but received the same error attempting the fologram connection.

I will email the log file as well, unable to upload .txt

  • Kevin

Fologram support, Cam worked with us to determine that the port number fologram was trying to access was being used by something else and thus blocking any server connection attempts. A simple remap to port #10090 did the trick. Thanks dude!

Thanks @kmill

For posterity, the issue was that the port used by Fologram for Rhino was already in use by something else. The steps to resolve the issue were:

  1. In the Fologram tab, head to the “Network” tab.

  2. Change the “Port” to 10090

  3. Click the Play button on the status bar.
    image

If it’s worked, the status bar will change to green and say “Connected”. If it hasn’t it’ll remain as Grey.

Cheers