Devices not detecting aruco cube

i tried tracking an aruco cube with both hololens - 2 and a mobile phone, but it didn’t work,… there’s no data output from the component,…
is there anything else i need to do after changing the track markers’ setting to aruco cube? …
i have tried tracking aruco markers, and it works fine,…
thank you in advance !

Hi @bhonemo
Are you using the cube template from here? Aruco Marker Download


Yes, I’m using that template,…
but hey, for some reason, its working now,… may be some kind of bug ??
anyway, thanks for your suggestion, man

1 Like

Hello all :slight_smile:
I’m testing Aruco markers on Fologram and they are not detected both by Holo2 and Mobile. Also in my case the GH component is giving a null list. The markers were downloaded from [Aruco Marker Download] and I’ve activated the marked detection on the devices. GH references are taken from (The 3 best ways to track live geometry in mixed reality with Fologram).
Do you have any suggestions?

Thanks in advance.

Hi @AndreaGentile

Try using the attached Grasshopper definition (it is only two components) and the attached Aruco marker sheet and letting me know if anything is detected. To try and give everything the best chance of working: (3.5 KB)
ArucoMarkers.pdf (85.6 KB)

  1. Make sure the Fologram app is up to date and restart your phone
  2. Make sure your Camera lens is clean and you’re in a space with neutral lighting (not especially dark or bright)
  3. Print off the attached marker sheet on A4 and at 100% scale. Cut out the first marker and ensure that you leave all of the white space around the marker - it will be very difficult to detect otherwise.
  4. Open the attached definition in Grasshopper, start Fologram and connect your phone.
  5. Go to Settings on your phone and double check that Aruco Marker tracking is enabled (it’s always worth double checking!)
  6. Then hold the marker in front of your phone so that the code fills about 50% of the screen. Take care that your fingers don’t cover any of the actual marker. Verify that the marker appears in Rhino (you should see a red rectangle) and the component outputs data in Grasshopper.

If this still doesn’t sort things out then I would suggest trying a different mobile device and a different PC / laptop and seeing if that addresses the issue.

Thank you Gwyll,

My mobile phone is finally tracking the Aruco markers, it will be really usefull for my future research.In the next days I’ll test it also on Holo 2 as to be sure.
Probably I’m in trouble with the “assign transform” component, as using your simple script is actually working.

Best, ALG :slight_smile:

Similar question, except that both mobile and Hololens 2 are tracking aruco markers, yet the mobile seems to track much faster. On Hololens 2, I thought it wasn’t working at first, but then I realized that it takes at least 20 seconds or so for the device to register the location of the aruco marker. Any advice for more real time tracking?

My class is back up and running this semester, and hoping to use this feature to place objects and direct tools.


Hey @erb02 can you please send me the GH definition you’re using and I’ll take a look?

Track tool.3dm (62.4 KB)
Track (21.7 KB)

Just coming back to this. Here are the files. Just checked again, and it’s working quite quickly on the phone app. Will check the Hololens 2 again soon.