Help with turning off gestural inputs when using MS HL2

Hi All,

Whilst I am working in the holographic space with the HoloLens2, The hand rays and clickers keep interfering with elements within the working environment (I am sure there is an easy step here that I am missing) Is there a way to turn these off? I have tried the short rays option but that doesn’t seem to help.

Seeking some advice with this,

Best
Anthony

Hi Anthony - do you mean moving your Rhino geometry around by accident? You can lock any Rhino layers that you don’t want to be able to interact with to prevent this using either the Layers panel in Rhino or in Fologram on the HoloLens.

If I’ve misunderstood your question let me know - perhaps share a little more about the project you are working on and what you’re trying to do.

Hi Gwyll,

Thank you for the prompt reply,

It is more of an issue that I can hear the finger clicks and menus are getting activated. for example, if I am holding a part or something like a glue gun, it will activate the Fologram menu.

I will lock the layers in Rhino though, that is a good idea.

I am doing a super simple matching exercise, where I have physical parts I am arranging according to their digital twins. But I have had this issue with other tasks also, maybe it is an issue with the HL2?

I have attached an image of what I am working on at present. I am trying to to place parts in the correct physical location in relationship to a Rhino / GH model. I have noticed that I can get a part in the correct spot from one viewing perspective, but if I move around the workspace, it no longer lines up?

Cheers

Anthony

Hi Anthony,

This will seem like a very analogue fix but you could try wearing black gloves during the assembly as the HoloLens has a really hard time detecting these! We don’t have any way to disable the detection of gestures so if the HoloLens is interpreting you holding the glue gun as a ‘tap and hold’ gesture then we can’t do much more about it.

In terms of the alignment issue - looks like a great project. The error you are seeing looks like it is being caused by either incorrectly rendered depth due to miscalibration, drift, incorrect model placement or an error in the way we are generating outlines. My guess is that there are a few things that could be going on here:

  1. The IPD setting on the HoloLens could be a little incorrect for your eyes. Because you are on the HoloLens 2 this is fairly unlikely, but you could try running the calibration app again.
  2. The HoloLens could be sitting a little high or low on your head, or the HoloLens display may not be fully lowered and this could be leading to incorrect depth rendering
  3. You might be experiencing really bad drift due to working in a dark space at night (my guess from your photos). Because the model is really small this is pretty unlikely but you could repeat this process in an environment with brighter and more uniform lighting (avoid harsh moving shadows) and see if it improves results.
  4. Because the Outline setting in the material is only displaying the silhouette it could be that there are several different ways to ‘fit’ the part to this silhouette for any given view. You could try also streaming over the wireframe of the model to Fologram to see if you can use this for alignment as well, perhaps it would make it easier.
  5. It is always possible there is a bug on our end that would be deforming the rendered outlines. I wouldn’t want to consider this until exploring 1,2,3 and 4 though.

Hi Gwyll,

Thank you for those suggestions, I will give it a go and update you on progress.

Cheers
Anthony

Hi Gwyll,

An update with my progress,

Yep Black Gloves do the trick!

I am still having Holographic calibration issues:

  1. I have run the HL2 calibration that seems to be OK (although, I have noticed the confirmation screen at post-calibration is on an angle and not completely square on) and have cleared holograms from the device and walked around my workspace for approx 5 mins.
  2. I have adjusted the headset and tried it across a variety of positions.
  3. Looked at different light set ups and background surface materials. I Will be trying a completely different environment tomorrow.
  4. I do not believe it is an issue on your end with the outlines, as I get the same issue with just streaming the geometry as is, across devices, (have also tried decimating mesh).
  5. I have also tried this on my IPad (6th version) and Samsung A51 phone and I am getting the exact same issue? So i do not think its the HL2?
  6. Could it be an issue with the origin QR code I am using? Have tried on multiple printers and same result. I have noticed that I need to continually keep snapping back to the origin as it drifts from 0,0,0 by about 10-12mm each session. At least it is a consistent problem.
  7. Do you have any different QR codes I could try to set the origin?
  8. I have used it across Rhino 6 & 7, same issue,
  9. I think it will be easier if I make a video tomorrow and email you a link, so you can probably see what the problem is and if I am doing something incorrect.

Love to know your thoughts and thank you for your help with this.
Cheers
Anthony

Hi @anthony,
Thanks for following up - we have a few more things to test, though it sounds like you are doing everything correctly.

However, I would suggest ensuring that your environment is roughly set up in accordance with Microsoft’s guidelines for good tracking: https://docs.microsoft.com/en-us/hololens/hololens-environment-considerations

Perhaps lets try some simpler tests first to gauge the drift you seem to be experiencing:

  1. Clear all holograms, restart the device, ensure all sensors are clean with the microfibre cloth.
  2. Walk around the space slowly for a period of time as you did previously.
  3. Connect Fologram. With a blank Rhino document, try snapping to the QR code. Then, slowly move (physically) to the other side of the QR code. The CPlane should still be in the same spot.
  4. Add a small box (say 2x2mm) in Rhino, a small distance from the origin (say 200,200,0). Using a pen, draw a cross on your work surface (or paper, etc) where the hologram shows. Walk to the other side of the object. Is it in the correct position? If not, could you diagram the direction that it is out?

Note - to verify the QR code you can measure it with a rule to ensure it’s the correct size. If you want to generate more or use different paper sizes etc, see here: Using the FologramQR command to create placement markers

Also - when you’re getting this issue with the iPad or A51, does the drift occur in the same direction?

One last thing I would note is that you may find it easier to use mesh pipes rather than outlines as it could be easier to perceive depth - but also as a general rule it’s often helpful to move around the objects when positioning again due to depth perception.

Cheers
Cam

Quick up-date to section 3.
I have tried out the procedure in a different environment setting, still have the same issue.
Will work on Cam’s suggestions next

Hi Cam,

Thank you for the input, I have tested the procedure for the small box and it works!
When I view it from any angle the hologram is locked in place, (despite the crappy lighting I have here)

However, when I go back to my other file, The same issue still occurs? I have attached an image of the issue I get and where the drift is most pronounced, I actually think its losing the origin snap point.

Cheers
Anthony

Hi Anthony,
Thanks for performing that test, very useful! Since that test shows everything correctly in place we can rule out poor tracking as the cause.

Am I correct that saying in your diagram, once you’ve done a 360 degree rotation of the object it appears back in place again? If that’s the case, it would suggest IPD as the issue - as holograms being drawn too close or too far to the user is directly caused by this. Is that the case?

Do you mind attaching your file or emailing it to support@fologram.com so I can take a look?
I’m trying to determine which variables remain between the successful cube test and the drifting task you’re attempting to accomplish. What comes to mind is:

  • if the geometry is heavy and frame rate is poor, tracking may be affected
  • possibly something strange with outline rendering (note that outline rendering is also much more graphically taxing than normal rendering)
  • IPD/calibration as mentioned above

Cheers
Cam

Hi Cam,

Thank you for the update,

Yes that is correct when I move around the workspace the objects drift, when I return to the initial position they are all back in place. (Bottom left corner of diagram).

Have sent you the files via email,
Look forward to your feedback

Cheers
Anthony

Thanks Anthony,
Will switch this discussion over to support to send files back and forth.

Cheers
Cam

Hi Cam,

So I have used the file you have sent me and its working alot better.

90% of the time now the holograms stay anchored to the object when I move about the room. I am still getting say 10-15mm of drift at certain angles, but I think its the lighting in my apartment which is poor, But huge improvement from before! (furthermore, if I resnap to the origin it usually fixes it).

I am going to try in different lighting conditions at work / uni over the next few days, will keep you updated on progress.

Thank you so much for your help thus far.

Cheers
Anthony