QR code - place model + rotate model by rotating QR code

Hi,

Probably an easy question but I can’t find it.

I managed to get my model into VR. And really like it :slight_smile:.

However, there is still 2 things that I dont get (after a lot of attempts).
I printed the QR-code, activated the fologramQR command, drew the QR code in Rhino. And got the model on top of the QR code.

Unfortunately:

  1. When scanning my physical QR code- (the model is placed) however, it is not placed on the corresponding QR code location (physical vs reality).
  2. I would like to rotate the physical QR-code, and by doing this, also rotating the model geometry (as if the model was pinned on top of the QR code).

When reading the article below, I think this should be possible. However I don’t know how/when to enter the rotation=yes command?

Do you have any hint on what I miss? or is there a video where this is explained in more detail?

Thank you in advance :slight_smile:

Hi @knippie5

The ‘Include_Rotation’ option has been removed from the most recent public release of the software - this option was simply allowing the user to toggle whether or not the model would rotate to align to the QR code, or if it would just place the model at the location of the QR code.

In terms of your issues, could you give me a little more information to help me isolate the problem you’re having?

  1. When you say your model is ‘not placed on the corresponding QR code location’, do you mean the model is not aligning perfectly to the QR code, or is it not locating itself at the QR code at all? It would be great to see a screenshot to get a better understanding as to what you mean
  2. When you say you want to rotate the QR code and rotate the geometry, are you talking about a live rotation (ie the QR code moves and the model follows it), or just the ability to rotate your model around the QR code’s location?

The best demonstration of how to use the QR code is in our DF2020 workshop video, which you can check out here.

Let me know of that helps!

Hi,

Thanks for your answers.
Here is some more explanation:

  1. In Revit my ‘model’ is located in the corner of the QR code. I thought if I scanned the QR code he’d be in the same (corner) position in on the ‘real’ physical QR code. This is not the case. He is at a different position. (should this be the same?)
    image

  2. yes, I mean a live rotation (QR code moves, the model follows automatically). The tutorial shows only that you can ‘replace’ the model again by, scanning again, correct?
    Would there be a possibility to make it a 'live rotation?

Thank again!

Hi @knippie5, thanks for the detailed explanation. Could you send me your QR code and Rhino file and I can take a look. Just a couple of things that could be causing the issue that you could check on your own:

  • Are you using the latest Fologram for Rhino plugin? (you should be prompted with an update message upon starting Rhino up, otherwise you can download it from here)
  • When printing the QR code, make sure you print with no scaling (don’t select ‘fit to page’)
  • It looks like you’re trying to use a QR code that is basically at the origin point in Rhino. Have you tried it with one of our default Origin QR codes? (you can download one here)

In terms of the live tracking, I would recommend trying out Fologram’s ‘Track Markers’ component in Grasshopper, and use an Aruco marker (these are better for live tracking than QR codes). You can read about how to setup live marker tracking in this article.

Hi @Sean Sean,

Thank you for your explanation!
The QR code with the origin, is working correctly now :slight_smile:.

To get the ‘live rotation’, I tried the Track markers component with Aruco marker.
I followed the article and did try the example file. Unfortunately the location is only ´updated, If the camera is fully ´on top´ of the Aruco. see attached GH file.
This while in the introduction to fologram on youtube (https://youtu.be/_3ylx_4J6nw 3:01:50) , It is working way better (updates live) rather than only when scannen from top view.

For your info, I did tick the ‘Aruco Marker Tracking’ in the fologram app.

Do you have any suggestion what is going wrong?

Thank you in advance.

2020-07-25 1.13 Track Markers.gh (7.9 KB)

Hi @knippie5, a couple of things that will help the tracking of aruco markers:

  • Make sure the size of your printed Aruco marker matches the size specified in Grasshopper. This can be changed by right clicking on the ‘Track Markers’ component and adjusting the size of the marker (by default it is set to 45mm which is the default printing size)
  • Try cutting and tracking one marker to begin with (as opposed to the multiple that appear on the template sheet).
  • A little obvious, but just make sure your printer is printing the markers off as a solid black with no extra white artifacts, as this could affect the efficiency of the tracking

Let me know if that helps getting it to work!

Hi Sean,

Thank for your answer.

I checked all 3 things, but unfortunately they are already ok.
I think it has something to to with a setting/grasshopper or divese, that it is only scanning the Aruco, from the top, instead of continuously liver updating the aruco, (also when not fulle on top)?

Thanks again! :slight_smile:

Hi @knippie5, hmm strange that it doesn’t work for you like it did for me in the webinar video you posted. What kind of device are you using to track (iPhone/Samsung/Tablet)? It might be worth just doing a quick test with a second device if you have one and see of the issue is repeatable. I’ll have a test myself on a few different devices to see if I can repro.

What size are your markers printed at?

Hi!

Thanks again :).
I am using a samsung S9.
And printed the aruco on an A4 paper (9aruco’s), after I cut 1 out.
In Grasshopper there are several ‘modes’ on the aruco command, I put it on ‘always’ is that correct?
I will try to do it also on another device and findout.

Thanks again!

Hi @knippie5, did you have any luck with a different device? Just an update on my end: I’ve tested with both an iPhone 6S and a Samsung Galaxy S7. With both devices I was able track Aruco markers from the side, however I did notice the Samsung was less responsive than the iPhone. This may mean it could be to do with your device camera. You should have your ‘Track Markers’ set to ‘Always’ and ‘Aruco Marker’ for live tracking.

Hi Sean,

Thanks again.
To be honest I did not try it on another device. (And I have an S9, so I think this should be oke (or at least equal to the S7).
Could you send me the GH - code, So I can really test it 1:1?

Thank you :slight_smile: